Cisco Adaptive Security Appliance Virtual Private Network SSL Client Certificate Bypass

Authors:Cisco ASA           Risk:High

CVE:CVE-2018-0227          0day:Certificate Bypass

0day -id:0DAY-176110        Date:2018-04-27

Summary

A Vulnerability in the Secure Sockets Layer (SSL) Virtual Private Network (VPN) Client Certificate Authentication feature for Cisco Adaptive Security Appliance (ASA) could allow an unauthenticated, remote attacker to establish an SSL VPN connection and bypass certain SSL certificate verification steps.

The vulnerability is due to incorrect verification of the SSL Client Certificate. An attacker could exploit this vulnerability by connecting to the ASA VPN without a proper private key and certificate pair. A successful exploit could allow the attacker to establish an SSL VPN connection to the ASA when the connection should have been rejected.

Cisco has released software updates that address this vulnerability. There are no workarounds that address this vulnerability.

Affected Products

Vulnerable Products

This vulnerability affects Cisco Adaptive Security Appliance (ASA) and Firepower Threat Defense (FTD) Software that is running on the following Cisco products:

  • 3000 Series Industrial Security Appliances (ISA)
  • ASA 5500 Series Adaptive Security Appliances
  • ASA 5500-X Series Next-Generation Firewalls
  • ASA Services Module for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers
  • Adaptive Security Virtual Appliances (ASAv)
  • Firepower 4110 Security Appliances
  • Firepower 9300 ASA Security Modules

To be considered vulnerable, the ASA or FTD has to be configured for Client Certificate Authentication. Administrators can check for a vulnerable configuration using the show running-config tunnel-group | include authentication | include certificate command. If either the authentication certificate or authentication multiple-certificate configuration option is present in the configuration then the device is vulnerable. The following is an example of a vulnerable configuration:

asa# show running-config tunnel-group | include authentication | include certificate
authentication certificate
authentication multiple-certificate

Vulnerable ASA Software

ASA Software is only vulnerable if running one of the following software versions:

Release 9.4
ASA software versions 9.4.3.1, 9.4.3.2 and 9.4.4 through 9.4.4.13

Release 9.5
ASA software versions 9.5.2.7, 9.5.2.8 and 9.5.3.7 through 9.5.3.9

Release 9.6
ASA software versions 9.6.2.9 through 9.6.2.21 and 9.6.3 through 9.6.3.17

Determining the ASA Software Release

To determine whether a vulnerable version of Cisco ASA Software is running on a device, administrators can use the show version | include Version command in the CLI. The following example shows the output of the command for a device that is running Cisco ASA Software Release 9.4(4):

ciscoasa# show version | include Version
Cisco Adaptive Security Appliance Software Version 9.4(4)
Device Manager Version 7.4(1)

Customers who use Cisco Adaptive Security Device Manager (ASDM) to manage devices can locate the software release in the table that appears in the login window or the upper-left corner of the Cisco ASDM window.

Vulnerable FTD Software

FTD software is only vulnerable if running one of the following software versions:

Release 6.0

FTD software versions 6.0 through 6.0.1.4.

Release 6.1
FTD software versions 6.1.0 through 6.1.0.5.

Determining the Running FTD Software Release

Administrators can use the show versionCLI command to determine the FTD release. In this example, the device is running software release 6.1.0.

> show version
---------------------[ ftd ]---------------------
Model : Cisco ASA5525-X Threat Defense (75) Version 6.1.0 (Build 362)
UUID : 2849ba3c-ecb8-11e6-98ca-b9fc2975893c
Rules update version : 2017-03-15-001-vrt
VDB version : 279
----------------------------------------------------
  • Products Confirmed Not Vulnerable

    Cisco has confirmed that this vulnerability does not affect Firepower 2100 Series Security Appliances.
    No other Cisco products are currently known to be affected by this vulnerability

Workarounds

  • There are no workarounds that address this vulnerability.

Fixed Releases

Customers should upgrade to an appropriate release as indicated in the table(s) in this section. To help ensure a complete upgrade solution, consider that this advisory is part of a collection that includes the following advisories:

In the following table(s), the left column lists major releases of Cisco software. The center column indicates whether a major release is affected by the vulnerability described in this advisory and the first minor release that includes the fix for this vulnerability. The right column indicates whether a major release is affected by all the vulnerabilities described in this collection of advisories and the current recommended release for those vulnerabilities.

ASA Software

Cisco ASA Major Release  Recommended Fixed Release for This Vulnerability Recommended Fixed Release for All the Vulnerabilities Described in the Collection of Advisories
Prior to 9.11 Not vulnerable 9.1.7.20
9.1 Not vulnerable 9.1.7.20
9.2 Not vulnerable 9.2.4.27
9.31 Not vulnerable 9.4.4.14
9.4 9.4.4.14 or later 9.4.4.14
9.51 Migrate to 9.6.3.20 9.6.4.6
9.6 9.6.3.20 or later 9.6.4.6
9.7 Not vulnerable 9.7.1.24
9.8 Not vulnerable 9.8.2.28
9.9 Not vulnerable 9.9.2.1

1Cisco ASA Software releases prior to 9.1 and ASA releases 9.3 and 9.5 have reached End of Software Maintenance. Customers should migrate to a supported release.

The software is available for download from Cisco Software Center by navigating to Products > Security > Firewalls > Adaptive Security Appliances (ASA) > ASA 5500-X Series Firewalls where there is a list of ASA hardware platforms. The majority of these software releases are listed under Interim.

FTD Software

Cisco FTD Major Release  Recommended Fixed Release for This Vulnerability   Recommended Fixed Release for All the Vulnerabilities Described in the Collection of Advisories
6.0 Migrate to 6.1.0.6 Cisco_FTD_SSP_Hotfix_EI-6.1.0.7-2.sh (41xx and 9300 FTD hardware platform)

Cisco_FTD_Hotfix_EI-6.1.0.7-2.sh (All FTD hardware platforms except 41xx and 9300)

6.0.1 Migrate to 6.1.0.6 Cisco_FTD_SSP_Hotfix_EI-6.1.0.7-2.sh (41xx and 9300 FTD hardware platform)

Cisco_FTD_Hotfix_EI-6.1.0.7-2.sh (All FTD hardware platforms except 41xx and 9300)

6.1.0 6.1.0.6 or later Cisco_FTD_SSP_Hotfix_EI-6.1.0.7-2.sh (41xx and 9300 FTD hardware platform)

Cisco_FTD_Hotfix_EI-6.1.0.7-2.sh (All FTD hardware platforms except 41xx and 9300)

6.2.0 Not vulnerable 6.2.0.5
6.2.1 Not vulnerable Cisco_FTD_SSP_Hotfix_BD-6.2.2.3-4.sh.REL.tar (41xx and 9300 FTD hardware platforms)

Cisco_FTD_SSP_FP2K_Hotfix_BD-6.2.2.3-4.sh.REL.tar (21xx FTD hardware platform)

Cisco_FTD_Hotfix_BD-6.2.2.3-4.sh.REL.tar (All other FTD hardware platforms)

6.2.2 Not vulnerable Cisco_FTD_SSP_Hotfix_BD-6.2.2.3-4.sh.REL.tar (41xx and 9300 FTD hardware platforms)

Cisco_FTD_SSP_FP2K_Hotfix_BD-6.2.2.3-4.sh.REL.tar (21xx FTD hardware platform)

Cisco_FTD_Hotfix_BD-6.2.2.3-4.sh.REL.tar (All other FTD hardware platforms)

6.2.3 Not vulnerable Cisco_FTD_SSP_Hotfix_A-6.2.3.1-10.sh.REL.tar (41xx and 9300 FTD hardware platforms)

Cisco_FTD_SSP_FP2K_Hotfix_A-6.2.3.1-10.sh.REL.tar (21xx FTD hardware platform)

Cisco_FTD_Hotfix_A-6.2.3.1-10.sh.REL.tar (All other FTD hardware platforms)

 

The software is available for download from Cisco Software Center by navigating to Products > Security > Firewalls> Next-Generation Firewalls (NGFW) where there is a list of FTD hardware platforms.

Source

This vulnerability was resolved during resolution of a Cisco TAC Support case.

Revision History

  • Version Description Section Status Date
    1.1 Updated metadata. No text changes. None Final 2018-April-27
    1.0 Initial public release Final 2018-April-18

Leave a Reply