Artifex Software Ghostscript pprintg1 Function Buffer Overflow

Authors:Ken Sha                Risk:Medium

CVE:CVE-2018-10194            0day:Buffer Overflow

0day-id:0DAY-10194             Date:2018-04-22

Summary

A vulnerability in the pprintg1 function of Artifex Software Ghostscript could allow an unauthenticated, remote attacker to execute arbitrary code or cause a denial of service (DoS) condition on a targeted system.

The vulnerability is due improper handling of postscript file data written to PDF. An attacker could exploit this vulnerability by persuading a targeted user to open a PDF file that submits malicious input to the affected software. A successful exploit could trigger a buffer overflow condition in the pprintg1 function of the software, which the attacker could use to execute arbitrary code or cause the affected application to crash, resulting in a DoS condition.

Artifex Software has confirmed the vulnerability and released software updates.

Analysis

To exploit the vulnerability, the attacker must have local access to the targeted system or use misleading language or instructions to persuade a user to open or execute a PDF file that submits malicious input to the system.

Safeguards

Administrators are advised to apply the appropriate updates.

Administrators are advised to allow only trusted users to have network access.

Users are advised not to open email messages from suspicious or unrecognized sources. If users cannot verify that links or attachments included in email messages are safe, they are advised not to open them.

Users are advised not to visit websites or follow links that have suspicious characteristics or that cannot be verified as safe.

Administrators are advised to use an unprivileged account when browsing the Internet.

Administrators are advised to monitor critical systems.

Vendor Announcements

Artifex Software has released a changelog at the following link: 
pdfwrite – Guard against trying to output an infinite number

Fixed Software

Artifex Software has released software updates at the following link: Ghostscript 9.23

Revision History

Version Description Section Date
1 Initial public release. 2018-April-20

Affected Products

The security vulnerability applies to the following combinations of products. 

Primary Products
Artifex Software Inc. ghostscript 5.50 (Base) | 6.01 (Base) | 6.50 (Base) | 7.0 (Base) | 7.03 (Base) | 7.04 (Base) | 8.0 (Base) | 8.10 (Base) | 8.11 (Base) | 8.12 (Base) | 8.30 (Base) | 8.31 (Base) | 8.32 (Base) | 8.33 (Base) | 8.50 (Base) | 8.51 (Base) | 8.52 (Base) | 8.53 (Base) | 8.54 (Base) | 8.56 (Base) | 8.57 (Base) | 8.60 (Base) | 8.61 (Base) | 8.62 (Base) | 8.63 (Base) | 8.64 (Base) | 8.70 (Base) | 8.71 (Base) | 9.00 (Base) | 9.01 (Base) | 9.02 (Base) | 9.04 (Base) | 9.05 (Base) | 9.06 (Base) | 9.07 (Base) | 9.09 (Base) | 9.10 (Base) | 9.14 (Base) | 9.15 (Base) | 9.16 (Base) | 9.18 (Base) | 9.19 (Base) | 9.20 (Base) | 9.21 (Base) | 9.22 (Base)

Leave a Reply